[VSA9] - [EU - VSA114] - Service Disruption

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Aug 28, 2026 - 14:23 EDT

Update

We are continuing to investigate this issue.
Posted Aug 28, 2026 - 13:16 EDT

Investigating

We are experiencing service disruption on EU - VSA114 Server, which may impact administrators ability to manage endpoints.

We are aware of the issue, and our team is actively working to resolve the same.

We apologize for any inconvenience.

- Kaseya Cloud Operations Team
Posted Aug 28, 2026 - 13:13 EDT
This incident affected: VSA 9 (EU - VSA114).