Autotask PSA - AE03, AW03 - Dashboards Not Loading

Incident Report for Kaseya Inc

Monitoring

A fix has been implemented and we are monitoring results
Posted Aug 29, 2025 - 15:35 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 29, 2025 - 13:32 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 29, 2025 - 10:50 EDT

Investigating

We are aware of an issue where some customers within the AE zones are experiencing latency when accessing Dashboards.

The appropriate teams are currently investigating.
Posted Aug 29, 2025 - 08:33 EDT
This incident affects: Autotask PSA (America East 3, America West 3).