Datto SaaS Protection- Partner Portal Outage - 500 Service unavailable

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 22:42 EDT

Investigating

We are aware of a problem when attempting to access Datto Partner Portal for Datto SaaS Protection generates a 500 error on login.

The Kaseya R&D Team is currently investigating the issue.
Posted Jun 17, 2025 - 22:16 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Backups, SaaS Protection Console Login, SaaS Protection Client Onboarding).