Datto Partner Portal - Persistent “Urgent Data Retention” Banner

Incident Report for Kaseya Inc

Postmortem

On May 5th, 2025 at 6:42 PM, BCDR Partners experienced a service interruption where users were unable to dismiss the pop-up notice, preventing site navigation.

The root cause for this service interruption was caused by an implementation of a notification feature that caused a disruption in page management for Datto BCDR partners with archived agents

Our Engineering team deployed a fix to correct the problem on May 5th, 2025 at 11:08 PM.

To prevent this issue from occurring in the future, our engineering team is actively strengthening the quality assurance framework for notification features and optimizing rollback procedures to ensure a more effective and timely response to potential issues.

Posted May 07, 2025 - 09:06 EDT

Resolved

The issue has been identified and a fix is being implemented.
Posted May 06, 2025 - 00:26 EDT

Investigating

We are currently investigating an issue in the BCDR Partner Portal where the “Urgent Data Retention Update for Archived Agents” banner may continue to appear after selecting “OK. Got it!” or “Remind me later.” This behavior is preventing some users from navigating the portal as expected.

At this time, there is no workaround available. Our engineering team is actively working to identify the root cause and implement a fix as quickly as possible.

We understand the disruption this may cause and appreciate your patience while we work toward a resolution. Updates will be shared as soon as more information becomes available.
Posted May 05, 2025 - 19:56 EDT
This incident affected: Datto Partner Portal (Status Components, User Account Management).