Completed
The scheduled maintenance has been completed.
Posted Sep 05, 2026 - 08:59 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 05, 2026 - 07:01 EDT
Scheduled
On Saturday, September 5th, System maintenance is scheduled for the server listed below between 07:00 AM and 11:00 AM ET.
To support upcoming FIPS 140-3 compliance requirements, Kaseya will be enabling enhanced TLS security protections within your SaaS environment.
To ensure uninterrupted connectivity, any agents that have been offline for an extended period should be brought online and updated to the latest supported version prior to this maintenance. Agents that are not updated may be unable to reconnect once these security enhancements are enabled.
Following deployment, Kaseya will closely monitor platform health, agent communications, and overall service performance to ensure a smooth and successful transition.
During this maintenance, access to the UI will be interrupted.
We apologize for any inconvenience this may cause.
-Cloud Operations Team
Posted Sep 04, 2026 - 16:03 EDT
This scheduled maintenance affected: VSA 9 (US - IAD2VSA33, US - NA1VSA106, US - NA1VSA31, UK - SAAS02, UK - SAAS04, UK - SAAS08, UK - SAAS09, UK - SAAS12, UK - SAAS19, UK - SAAS20, UK - SAAS24, UK - SAAS25, UK - SAAS26, UK - SAAS27, UK - SAAS29, UK - SAAS34, UK - SAAS39, EU - EUVSA05, EU - EUVSA06, EU - EUVSA07, EU - EUVSA11, EU - EUVSA12, EU - EUVSA16, EU - SAAS11, EU - SAAS18, EU - SAAS21, EU - SAAS30, SYD2-TRIAL1003, US - VSA138, US - VSA141, US - VSA143).