Kaseya Quote Manager - Degraded performance and intermittent ability to access Web Application

Incident Report for Kaseya Inc

Postmortem

Summary:  

Between 2026-04-09T 22:15 UTC and 2026-04-10T 02:25 UTC, a small percentage of KQM customers experienced repeated gateway errors, slow loading across all pages, unexpected session expirations, and inability to save updates to quotes. 

   

Root Cause:  

This issue was caused by an unexpected spike in traffic into Kaseya Quote Manager 

   

Incident Timeline:  

  • Impact start time: 2026-04-09T 22:15 UTC 

  • Identified: 2026-04-10T 01:15 UTC 

  • Public Notification to the Status Page: 2026-04-10T 02:12 UTC  

  • Resolved: 2026-04-10T 02:25 UTC  

  

What we’re doing about it

  • Faster detection: Enhancements to monitoring and alerting so issues like this are caught sooner. 

  • Infrastructure resilience: Platform-level changes to ensure future unexpected traffic spikes do not impact the broader platform.

Posted Apr 10, 2026 - 12:31 EDT

Resolved

We have confirmed all systems are now functional.
Posted Apr 10, 2026 - 00:01 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 09, 2026 - 22:52 EDT

Monitoring

Our development team has implemented a fix and we are monitoring the results to ensure no further impact.
Posted Apr 09, 2026 - 22:51 EDT

Investigating

We are currently investigating impacted performance and access to Kaseya Quote Manager across all regions.

Thank you for your patience as work to resolve this. We will share an update as soon as it is available.
Posted Apr 09, 2026 - 22:12 EDT
This incident affected: Kaseya Quote Manager (Web Application).