Backup success rates on pod 'usw3-saas-p0' remain stable at normal levels. Our R&D team is continuing to monitor.
Posted May 12, 2026 - 16:30 EDT
Monitoring
Our R&D team has resolved the issue and Backup and Recovery services are functioning normally again for customers on pod 'usw3-saas-p0'. We are continuing to monitor.
Posted May 11, 2026 - 18:46 EDT
Identified
Our R&D team has identified another issue affecting Backup and Recovery services for customers hosted on pod 'usw3-saas-p0' and are actively working to address it.
Posted May 11, 2026 - 18:11 EDT
Monitoring
Our R&D team has implemented a fix to resolve the Backup and Recovery issues affecting customers on pod 'usw3-saas-p0' and are actively monitoring for any other issues.
Posted May 11, 2026 - 14:50 EDT
Investigating
We are aware of a problem where customers hosted on pod 'usw3-saas-p0' are experiencing a disruption to Backup and Recovery services for Datto SaaS Protection.