Datto SaaS Protection - Backup performance degradation for Exchange and Teams Services on Multiple Pods

Incident Report for Kaseya Inc

Update

We are continuing to work on a fix for this issue.
Posted Aug 03, 2026 - 08:31 EDT

Identified

We are aware of an issue where some Datto SaaS Protection customers may experience degraded backup performance for Exchange and Teams services.

The Kaseya R&D team has identified the issue and is actively working to restore normal backup performance as quickly as possible.

For the latest updates, please subscribe to the Kaseya Status Page at https://status.kaseya.com/.
Posted Aug 03, 2026 - 05:12 EDT
This incident affects: Datto SaaS Protection (SaaS Protection Backups).