Datto Workplace - File Uploads May Experience Delays for Files Exceeding 5MB In Size

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jun 06, 2025 - 11:41 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2025 - 08:27 EDT

Update

A resolution has been developed and is scheduled for deployment by mid-next week.
Posted May 30, 2025 - 14:02 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 22, 2025 - 10:05 EDT

Investigating

We are aware of a problem where Datto Workplace users can experience an issue where file uploads may experience delays for files exceeding 5MB in size; however, the upload process will complete successfully.



The Kaseya R&D Team is currently investigating the issue.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted May 20, 2025 - 09:39 EDT
This incident affected: Datto Workplace (AU5, CA3, EU2, EU4, EU7, EU16, US1, US6, US15).