We’re pleased to inform you that our Engineering team has released a fix that should resolve the problem where BCDR Agents operating on 32-bit versions of Windows Server 2003 and Windows XP are experiencing failures with screenshot verification, and local virtualization processes are not successfully initializing.
If the problem is still occurring, please make sure your device is fully up to date on the latest OS version.
Please note, we have started to roll out the update to devices on 05/11/2026 and the release will complete for all devices by 05/28/2026.
Thank you for your patience and understanding. We remain committed to delivering exceptional service and continuous improvement.
Best regards,
Posted May 14, 2026 - 15:41 EDT
Identified
Our R&D team has identified the underlying issue and is actively working toward a targeted resolution.
The deployment window is projected to commence upon completion of the current major device release.
In the interim, please utilize cloud‑based virtualization services to ensure continued operational continuity in the event of a Disaster Recovery scenario.
Please note: This issue is currently impacting only a limited subset of the Datto Windows Agent fleet.
Posted Mar 25, 2026 - 12:24 EDT
Investigating
We have identified an issue introduced in the latest device software release related to agents running 32 bit versions of Windows Server 2003 and Windows XP where screenshot verification and local virtualization fails to start.
We are currently investigating the issue to determine the cause and potential fix.
In the meantime, we have verified that cloud virtualizations are still functional for any DR scenarios. We will provide more information as it becomes available.
Posted Mar 24, 2026 - 16:11 EDT
This incident affected: Datto BCDR Devices (Verification, Recovery).