Service Disruption - VSA10

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 05:15 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 04:22 EST

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 04:12 EST

Investigating

We are currently experiencing a service disruption due to an ongoing Cloudflare incident. Our services may be slow or unavailable.

We are monitoring the situation and will provide updates as Cloudflare progresses with the fix.

Apologies for the inconvenience this may cause.

- Cloud Operations Team
Posted Dec 05, 2025 - 04:12 EST
This incident affected: VSA 10 (APAC, EU, US, US - Andromeda10, EU - Andromeda10, APAC-Hosted-1, Integration Services, License Management, US - Remote Control, EU - Remote Control, APAC - Remote Control).