IT Glue - Degraded Performance

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted May 13, 2025 - 13:22 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 13, 2025 - 12:36 EDT

Update

We are continuing to work on a fix for this issue. We will provide further details here as soon as we can.
Posted May 13, 2025 - 11:47 EDT

Identified

We are investigating performance issues that may prevent access to IT Glue for some of our partners. You may see error pages on certain pages in the app or a longer than usual load time. We will provide further details here as soon as we can.

Region: North America
Applications: Web App
Posted May 13, 2025 - 10:57 EDT
This incident affected: IT Glue (North America Primary Application Services, North America Primary File Services).