Datto RMM - Zinfandel - Delay in Job Execution

Incident Report for Kaseya Inc

Postmortem

On 25th April 2025 around 16:45 UTC, some Datto RMM partners on the Zinfandel (US WEST) platform experienced a service issue that caused Jobs to execute with a long delay.

The root cause of the incident was identified to be resource exhaustion of the service that handles Job queuing and execution: in spite of automatic scaling, the available resources were insufficient to handle all requests in real time at the time of this issue.

The Infrastructure team increased resolved the issue by cycling service tasks and manually scaling the infrastructure over the auto-scaling limit.

In the interest of mitigating the risk of recurrence, the Infrastructure team increased the baseline of resources available to the service.

Further investigation will be underway to identify opportunities to improve the efficiency of the supporting service.

Posted Apr 30, 2025 - 10:12 EDT

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 13:46 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 25, 2025 - 13:12 EDT

Investigating

We are aware of a problem where job execution my be delayed in Datto RMM on the Zinfandel Platform.

The Kaseya R&D Team is investigating the issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Apr 25, 2025 - 12:52 EDT
This incident affected: Datto RMM (Zinfandel (US West)).