Our R&D team has implemented additional changes to restore full functionality to affected customers and they are closely monitoring for any other issues.
Posted Aug 26, 2026 - 15:44 EDT
Identified
Our R&D team is continuing to address this issue and restore full functionality to the affected customers.
Posted Aug 26, 2026 - 13:06 EDT
Update
We are continuing to monitor for any further issues.
Posted Aug 26, 2026 - 08:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2026 - 19:57 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 25, 2026 - 17:48 EDT
Identified
We are aware of a problem where some Datto SaaS Protection customers hosted in multiple regions are experiencing backup and restore issues. Export services are not affected.
The Kaseya Engineering Team has identified the issue and are actively working to resolve it.