Datto SaaS Protection - Backup performance degradation for All app types on USE pods

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 08:27 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2025 - 12:21 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 09, 2025 - 10:30 EDT

Investigating

We are currently aware of a problem where Pod Degradation can be experienced for some customers hosted on the pods use1-saas-p0, use1-saas-p2, use1-saas-p3, use1-saas-p6.

The Kaseya R&D Team is currently investigating

Affected Pod : use1-saas-p0, use1-saas-p2, use1-saas-p3, use1-saas-p6

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 09, 2025 - 05:33 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Backups).