Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 07, 2026 - 17:01 EDT
Scheduled
We will be performing maintenance to Kaseya Technical Support Live Chat on Thursday May 7th, starting at 5 p.m. EST and concluding at 8 p.m. EST
During this maintenance window, there will be downtime for systems and related services for Kaseya Technical Support Live Chat as we migrate to a newer Kaseya Helpdesk portal.
Please note that;
• Customers or partners experiencing a Severity 1 (critical) issue during this window should call Support directly, or
• For technical support issues please create a new web case for assistance
We appreciate your patience as we perform this upgrade to improve your support experience
Subscribe to receive up-to-date notifications on this and future maintenance periods by visiting https://status.kaseya.com/
Posted May 07, 2026 - 12:16 EDT
This scheduled maintenance affects: Kaseya Product Support Contact Center (Chat).