Datto SaaS Protection - Backup performance degradation for various services on pod multiple pods

Incident Report for Kaseya Inc

Monitoring

A fix has been implemented and we are monitoring the results. Several pods have shows signs of improvement.
Posted Jul 12, 2026 - 08:13 EDT

Investigating

We are aware of a problem where some customers across multiple pods are experiencing backup performance degradation for various services. The affected pods and services are listed below.
'gbe2-pod-0' - SharePoint
'gbe2-pod-1' - SharePoint
'use1-pod-4' - SharePoint

The Kaseya R&D Team is actively Investigating the issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 11, 2026 - 12:07 EDT
This incident affects: Datto SaaS Protection (SaaS Protection Backups).