Intermittent Web Remote Connection Failures

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 07:42 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2026 - 22:15 EST

Investigating

Web Remote fails to connect and 502's.
Posted Jan 12, 2026 - 20:43 EST
This incident affected: Datto RMM (Syrah (APAC)).