Datto SaaS Protection - Service disruption for customers hosted on node 'Gbe2-saas-p0-app-2'

Incident Report for Kaseya Inc

Monitoring

The Kaseya R&D team has implemented changes to help address the issue and are monitoring the results closely.
Posted May 04, 2026 - 09:07 EDT

Investigating

We are aware of a problem where customers hosted on node 'gbe2-bfyii-327' are experiencing a disruption to their SaaS Protection services. Backups are still operational, but the platform is unable to be accessed.

The Kaseya R&D Team is investigating the issue and are actively working to resolve it.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted May 04, 2026 - 07:52 EDT
This incident affects: Datto SaaS Protection (SaaS Protection Backups, SaaS Protection Console Login, SaaS Protection Seat Management, SaaS Protection Client Onboarding, SaaS Protection Report Delivery, SaaS Protection Restores/Exports).