Kaseya Quote Manager - 504 error displayed for customers on specific servers when attempting to login

Incident Report for Kaseya Inc

Resolved

This behavior has now been fully resolved.
Posted Aug 07, 2025 - 17:53 EDT

Monitoring

A fix has been implemented to correct this behavior and results are being monitored closely.
Posted Aug 07, 2025 - 16:49 EDT

Investigating

The issue has been identified but a fix has not been implemented yet.
The Engineering Team is actively working to resolve this behavior as an escalated priority.
We thank you for your patience and understanding while we work to correct this.
Posted Aug 07, 2025 - 16:20 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 07, 2025 - 14:25 EDT

Monitoring

Our teams are currently investigating the 504 Front Door Error at this time. Thank you for your patience.
Posted Aug 07, 2025 - 14:09 EDT
This incident affected: Kaseya Quote Manager (Web Application).