VSA9 - Partial Service Disruption - US-NA1-VSA37

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Dec 06, 2025 - 18:28 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 06, 2025 - 17:42 EST

Investigating

We are currently experiencing partial service disruption for US-NA1-VSA37, where administrators may be unable to login to Ui.

Our team is working to restore the functionality on the affected instances at this time.

We apologize for any inconvenience.

- Cloud Operations Team
Posted Dec 06, 2025 - 15:54 EST
This incident affected: VSA 9 (US - NA1VSA37).