Kaseya Quote Manager - Sync issue with Autotask PSA integration

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 08:53 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2026 - 16:39 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 27, 2026 - 15:09 EST

Investigating

We are aware of a problem where entities in Kaseya Quote Manager, such as Organizations, Sales Orders, or Quotes, are not syncing to Autotask PSA.

The Kaseya R&D Team is currently investigating the issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jan 27, 2026 - 12:12 EST
This incident affected: Kaseya Quote Manager (Integrations).