Following our earlier update, we are continuing to monitor the environment and have identified additional infrastructure-related pressure contributing to intermittent latency.
We are seeing elevated system load driven by increased telemetry and system activity, which can create short-lived performance impacts as services recover. Our team is actively implementing changes to reduce this load and stabilize the platform.
We are taking a controlled approach to these changes to avoid further disruption, and performance is trending in the right direction.
We will continue to provide updates as we make progress. Thank you again for your patience.
Posted Apr 17, 2026 - 16:10 EDT
Update
We are continuing to monitor.
Some partners may still experience a temporary error when attempting to log in or navigate the Datto EDR platform. While service may return to normal on its own after some time, please contact our support team and they can apply a backend workaround that may assist with resolving the issue.
Posted Apr 17, 2026 - 14:12 EDT
Monitoring
We experienced a brief issue where some customers in the US region were unable to access the Datto EDR portal. This was due to a temporary service disruption that lasted a few minutes.
The issue has been identified and resolved, and access is now restored. We are continuing to monitor the system to ensure stability. We apologize for the disruption and appreciate your patience.