Datto Workplace AU5 - Agents are unable to connect and sync data; files cannot be created and/or saved in Workplace Online

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted May 06, 2026 - 08:45 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 05, 2026 - 09:50 EDT

Update

The R&D and Infrastructure teams are continuing to investigate the cause of the issue.
Posted May 05, 2026 - 07:14 EDT

Investigating

We are currently investigating an issue impacting partners on AU5 cell, where agent connections and file syncs are failing.
Affected partners may see server errors in the Workplace Agent with both versions.
Creating files in Workplace Online may fail with a 404 error.
Opening existing files with the Google Docs integration may fail with an error.
Saving changes to existing files through the Microsoft 365 integragration may silently fails.

Subscribe to the Kaseya Status Page for up to date information at https://status.kaseya.com/
Posted May 05, 2026 - 04:27 EDT
This incident affected: Datto Workplace (AU5).