The current estimated time for recovery of the software update services supporting the Kaseya Software Deployment and Update module (KSDU) is 2 weeks. During this time, it will not be possible to deploy or update software applications from the Ninite catalogue.
Please note that update and deployment of many software titles is natively supported within the Software Management (KSM) module using the VSA9 application catalog. Click here for a list of supported titles - https://help.vsa9.kaseya.com/help/Content/Modules/software-management/application-catalog.htm - please contact Support for assistance if you would like to utilize this solution and require assistance.
We apologize for any inconvenience.
- Cloud Operations Team
Posted Dec 01, 2025 - 09:14 EST
Investigating
We are aware that VSA9 customers using the Software Deployment module may be experiencing service disruption.
Our team is actively working to restore functionality at this time.
We apologize for any inconvenience.
- Cloud Operations Team
Posted Nov 26, 2025 - 14:06 EST
This incident affects: VSA 9 (Kaseya Software Deployment and Update).