Datto BCDR - Cloud Recovery - Cloud Operations Service Impact

Incident Report for Kaseya Inc

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2026 - 14:44 EDT

Update

The majority of BCDR servers have been successfully restored and are operating normally. A limited number of servers remain under remediation, and Engineering teams are actively working to complete recovery efforts and return all impacted systems to full operational status.
Posted Sep 04, 2026 - 10:19 EDT

Update

The remediation has been identified and is currently being deployed to the affected nodes in a phased rollout to ensure a controlled and efficient resolution.
Posted Sep 03, 2026 - 10:51 EDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2026 - 10:42 EDT

Identified

The Kaseya Systems Engineering Team identified the issue and they are working on resolving the problem.
Posted Sep 02, 2026 - 09:10 EDT

Update

The Kaseya Systems Engineering Team is continuing to investigate the issue.
Posted Sep 02, 2026 - 08:32 EDT

Update

We are continuing to investigate this issue.
Posted Sep 02, 2026 - 07:27 EDT

Investigating

We are aware of a problem where Cloud Operations are hindered for some of our Datto BCDR partners.

The Kaseya Engineering Team is investigating the issue.

Should you need any additional questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/contact

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Sep 02, 2026 - 06:10 EDT
This incident affects: Datto BCDR Devices (Off-Site Recovery).