Microsoft Azure Outage in US West Impacting Multiple Kaseya Products

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 17:19 EDT

Monitoring

A fix has been implemented by Microsoft Azure and we are monitoring the results.

Please refer to the Microsoft Status page here: https://azure.status.microsoft/en-us/status for more details
Posted Jul 23, 2026 - 14:40 EDT

Update

We have identified additional Kaseya Products that rely on Microsoft Azure Infrastructure that are affected by this issue.

Partners using Datto / Unitrends Backup for Microsoft Azure and Datto / Unitrends Endpoint Backup with Disaster Recovery in the US West region will experience issues with Device Check-In, Device Registration, and Back Up.

The Kaseya R&D team are continuing to work with the Microsoft Azure team to resolve this issue and we hope to have updates on a resolution as soon as possible.
Posted Jul 23, 2026 - 14:26 EDT

Update

Kaseya R&D are continuing to work closely with Microsoft Azure to resolve this issue affecting the KaseyaOne Portal.
Posted Jul 23, 2026 - 13:06 EDT

Identified

We have verified that the KaseyaOne Portal is being impacted by the Microsoft Azure Outage.

Please follow their Status Post as well for updates: https://azure.status.microsoft/en-us/status
Posted Jul 23, 2026 - 11:49 EDT

Investigating

We are aware of a problem where the KaseyaOne Portal is not accessible.

The Kaseya R&D Team is investigating the issue.

Should you have any questions or require assistance, please contact our support team at https://helpdesk.kaseya.com/hc/en-gb#/phone

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/

As a note; To ensure business continuity, for Kaseya modules using Require Log In with KaseyaOne, users must authenticate using their KaseyaOne Unified Login credentials. Users added as exceptions can still log in using local module-specific credentials. Details are available in this Knowledge Base article: https://help.one.kaseya.com/help/Content/1_Configuration/enable-require-login-with-K1.htm

We recommend adding a small set of users to the override list to maintain access in the event of a future disruption or maintenance, helping ensure continuous business operations
Posted Jul 23, 2026 - 11:15 EDT
This incident affected: Datto / Unitrends Backup for Microsoft Azure (Device Registration, Device Check-in, Backup), Datto / Unitrends Endpoint Backup with Disaster Recovery (Backup, Device Registration), and KaseyaOne.