Datto RMM - All Platforms - RMM Agent cannot be installed due to Certificate errors

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 08:27 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2026 - 07:43 EDT

Update

We are continuing to investigate this issue.
Posted Apr 02, 2026 - 17:09 EDT

Investigating

We are aware of a problem where the Datto RMM agent cannot be installed due to Certificate errors.

The Kaseya R&D Team are investigating the issue.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Apr 02, 2026 - 14:25 EDT
This incident affected: Datto RMM (Pinotage (EU1), Merlot (EU2), Zinfandel (US West), Concord (US East), Syrah (APAC), Vidal (US East)).