VSA10 - Service Degradation for subset of VSA10-US customers

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Feb 07, 2026 - 15:28 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2026 - 14:28 EST

Investigating

Subset of VSA10 US customers may be experiencing degraded performance, which may impact administrators' ability to manage endpoints.

We are aware of the issue and our team is actively working to resolve the same.

We apologize for any inconvenience caused.

- Cloud Operations Team
Posted Feb 07, 2026 - 03:11 EST
This incident affected: VSA 10 (US, US - Remote Control).