Datto SaaS Protection - Backup and recovery performance degradation for services on pod 'use1-saas-p6'

Incident Report for Kaseya Inc

Monitoring

After changes were implemented to address the issue, performance metrics for services are improving.

The Kaseya R&D team is continuing to monitor.
Posted Jun 12, 2025 - 12:46 EDT

Identified

We are currently aware of a problem where some Datto SaaS Protection customers hosted on pod 'use1-saas-p6' are experiencing degraded backup and recovery performance for services.

The Kaseya R&D Team has identified the issue and implemented changes to address it.

We are actively monitoring the results.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jun 12, 2025 - 08:53 EDT
This incident affects: Datto SaaS Protection (SaaS Protection Backups).