Datto SaaS Protection - 500 Error When Accessing SaaS Protection Status Page in Datto Partner Portal

Incident Report for Kaseya Inc

Resolved

We are aware of a problem where Datto SaaS Protection Partners were receiving a 500 error when attempting to access the SaaS Protection Status Page within the Datto Partner Portal.

The Kaseya Engineering Team quickly identified the issue and implemented a fix to restore SaaS Protection Status Page functionality.

Access to SaaS Protection customer accounts through the Datto Partner Portal has been fully restored.
Posted Sep 18, 2026 - 09:30 EDT