Datto SaaS Protection - Backup performance degradation for SharePoint and Teams services on pod 'des1-saas-p0'

Incident Report for Kaseya Inc

Update

Backup success rates for Teams and SharePoint services on pod 'des1-saas-p0' have stabilized at 2x backups per day.

The Kaseya R&D team is continuing to monitor.
Posted Mar 03, 2026 - 08:46 EST

Update

SharePoint and Teams success rates on the pod have stabilized and the Kaseya R&D team has increased backup frequency back to 2x backups per day.

We are continuing to monitor.
Posted Mar 02, 2026 - 08:40 EST

Update

The Kaseya R&D team have implemented additional configuration changes on the pod to address the issue further.

Sharepoint and Teams success rates are improving and the Kaseya R&D team is actively monitoring.
Posted Feb 27, 2026 - 14:05 EST

Monitoring

While the Kaseya R&D team continue to address the issue they have temporarily decreased the daily backup frequency on pod 'des1-saas-p0' from 2x per day to 1x per day to maintain high backup success rates amidst ongoing spikes in Microsoft throttling.

The Kaseya R&D team is closely monitoring success rates after the configuration change and will increase backup frequency to 2x backups per day when it is safe and reliable for all customers hosted on the pod.
Posted Feb 26, 2026 - 12:36 EST

Identified

We are aware of a problem where some Datto SaaS Protection customers hosted on pod 'des1-saas-p0' are currently experiencing degraded backup performance for SharePoint and Teams services.

The Kaseya R&D team has identified the issue and are actively working to resolve it.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Feb 26, 2026 - 09:11 EST
This incident affects: Datto SaaS Protection (SaaS Protection Backups).