Kaseya Store - Issues accessing invoices or making payments

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 17:35 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2025 - 14:50 EST

Update

We are continuing to work on a solution to resolve the error that displays when attempting to make a payment.

The fix requires coordination with a third-party vendor, and our R&D team is working closely with them to implement these changes.

In the meantime, if you need to process a payment, please contact our Billing & Payments team through our Helpdesk, and they will be happy to help you with the payment process.
Posted Nov 07, 2025 - 12:24 EST

Update

A fix has been applied to resolve the issue with open invoices not displaying, and we are currently monitoring the results.

Additional work is needed to correct the error that displays when attempting to make a payment. We will update again when further information is available.
Posted Nov 05, 2025 - 13:07 EST

Identified

We are aware of an issue where partners are unable to view open invoices or encounter an error when attempting to make payments.

The Kaseya R&D Team has identified the cause and is working on a solution.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Nov 05, 2025 - 11:08 EST
This incident affected: Kaseya Store.