Datto RMM - Vidal (US East) - Platform Maintenance
Incident Report for Kaseya Inc
Postmortem

On November 5, 2024, at 12:22 PM EST (5:22 PM UTC), partners on the Vidal (US East) platform experienced a service disruption that caused Managed Devices to go offline.

The incident was triggered by slower-than-expected recovery from emergency maintenance that was required to address an infrastructure issue.

The Datto RMM Infrastructure team, through their alerting systems, proactively identified database resource exhaustion on servers managing device sessions. To resolve this, they manually scaled the infrastructure and performed a failover. This action necessitated emergency maintenance to prevent further device offline alerts. During this time, a Kaseya Status page post was created to keep our partners informed.

The issue was confirmed resolved at 3:27 PM EST (8:27 PM UTC) on the same day.

To prevent a recurrence, the infrastructure team is currently reviewing platform utilization and growth projections to ensure sufficient resources are permanently allocated to support future demand.

Posted Nov 11, 2024 - 06:30 EST

Resolved
This incident has been resolved.
Posted Nov 05, 2024 - 16:25 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 05, 2024 - 15:23 EST
Identified
We will be placing the Vidal Platform back in Maintenance Mode as we continue to work on this issue where devices are falsely showing as offline.
Posted Nov 05, 2024 - 14:28 EST
Investigating
We are currently investigating an issue in which devices on the Vidal Platform are showing as offline.
Posted Nov 05, 2024 - 14:15 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 05, 2024 - 13:20 EST
Identified
In order to provide you with continued platform stability, we will be performing maintenance on this platform.

Expected Impact: Partners can expect that devices may reconnect, CSM and Agent Browser sessions may be closed, and there may be a brief period of slow down in functionality.
Posted Nov 05, 2024 - 12:50 EST
This incident affected: Datto RMM (Vidal (US East)).