Endpoint Backup V2 - Service Interruption

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 23:39 EST

Investigating

We are aware of a problem where Endpoint Backup v2 assets appear offline in UniView, agent check-ins time out, and scheduled backups fail to run across all regions.

The Kaseya R&D Team is currently investigating this issue.

Subscribe to receive up-to-date notifications on future maintenance periods by visiting https://status.kaseya.com/
Posted Nov 03, 2025 - 20:26 EST
This incident affected: Endpoint Backup V2 (Backup).