Datto SaaS Protection - Service disruption for customers hosted in GBE2 data center

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 15:08 EDT

Update

Both GBE2 pods are operational again and the Kaseya R&D team is continuing to monitor backup success metrics.
Posted Jun 10, 2025 - 08:20 EDT

Update

Pod 'gbe2-saas-p0' is currently operational and pod 'gbe2-saas-p1' is still actively being monitored by the Kaseya R&D team after the fix was implemented.
Posted Jun 09, 2025 - 16:49 EDT

Monitoring

A fix has been implemented and the Kaseya R&D team is actively monitoring the results.
Posted Jun 09, 2025 - 11:32 EDT

Identified

We are aware of a problem where SaaS Protection customers hosted on pods within the GBE2 data center may not be able to access their accounts and are experiencing impacts to services.

Affected pods:
'gbe2-saas-p0'
'gbe2-saas-p1'

The Kaseya R&D Team has identified the issue and are working to address it.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jun 09, 2025 - 10:08 EDT
This incident affected: Datto SaaS Protection (SaaS Protection Backups, SaaS Protection Console Login, SaaS Protection Seat Management).