Datto Endpoint Backup for PC - Users encounter a failure when attempting to pair an agent or modify agent configuration settings

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 14:28 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 26, 2025 - 13:13 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2025 - 11:19 EDT

Investigating

We are aware of a problem where Datto Endpoint Backup and Datto Endpoint Backup for PC assets can experience an error when attempting to pair an agent or modify the agent settings.



The Kaseya R&D Team is currently investigating the issue and working towards a resolution.



Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 26, 2025 - 10:25 EDT
This incident affected: Datto / Unitrends Endpoint Backup (Agent Registration) and Datto / Unitrends Endpoint Backup for PCs (Agent Registration).