Datto SaaS Protection - Backup performance degradation for some SharePoint/Teams services on pod 'gbe2-saas-p2'

Incident Report for Kaseya Inc

Update

Backup success rate metrics for SharePoint/Teams services on pod 'gbe2-saas-p2' remain stable at normal levels.

Our R&D team is continuing to monitor.
Posted Jul 31, 2026 - 09:58 EDT

Update

Backup success rates for SharePoint/Teams services on pod 'gbe2-saas-p2' are currently stable at normal levels.

Our R&D team is making additional adjustments to the configuration on the pod to further address the issue and will continue to monitor.
Posted Jul 30, 2026 - 11:48 EDT

Update

Backup success rates for SharePoint/Teams services on pod 'gbe2-saas-p2' have returned to normal levels.

Our R&D team is continuing to monitor.
Posted Jul 29, 2026 - 11:20 EDT

Monitoring

Backup success rates for SharePoint/Teams services on pod 'gbe2-saas-p2' are improving after the changes made on the pod earlier today.

Our R&D team is continuing to monitor.
Posted Jul 28, 2026 - 16:07 EDT

Update

Our R&D team has implemented changes on pod 'gbe2-saas-p2' to mitigate the backup performance issues affecting some SharePoint and Teams services.
Posted Jul 28, 2026 - 14:02 EDT

Identified

We are aware of a problem where some Datto SaaS Protection customers hosted on pod 'gbe2-saas-p2' may be experiencing backup performance degradation affecting some SharePoint/Teams services.

The Kaseya Engineering Team has identified the issue and are actively working to resolve it.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Jul 28, 2026 - 08:47 EDT
This incident affects: Datto SaaS Protection (SaaS Protection Backups).