Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Mar 11, 2026 - 17:21 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 11, 2026 - 07:05 EDT
Scheduled
Our payment provider for KaseyaOne and Kaseya Store has announced a scheduled maintenance window on March 11th, 2026 from 7:00 AM - 3:00 PM EDT.
During this time, users may experience intermittent issues related to payment processing in KaseyaOne and Kaseya Store. This may include:
> Adding, updating, or removing payment methods > Completing Store purchases > Processing subscription or billing transactions
Core platform functionality outside of payment services will remain unaffected.
We recommend avoiding payment-related actions during this maintenance window where possible. We will monitor the situation and provide updates if necessary.
Posted Mar 11, 2026 - 07:02 EDT
This scheduled maintenance affected: KaseyaOne and Kaseya Store.