Datto RMM - All Platforms - Login Errors when using KaseyaOne
Incident Report for Kaseya Inc
Postmortem

On 15th November, 2024 at 04:30AM EST RMM some partners using the KaseyaOne Portal's SSO Integration with Datto RMM experienced an intermittent service issue that resulted in receiving an error page after successfully authenticating through KaseyaOne SSO to Datto RMM.

The root cause of this service incident was identified to be an unexpected interaction during SSO authentication between products after a recent code change. The issue occurred in an edge case, intermittently, when the login flow was delayed due to network latency between a user's environment and our infrastructure.

Re-trying the login through SSO had a good chance of making the request successful given the nature of the issue.

In order to resolve the issue the R&D team reverted the related change, and they will explore a more robust implementation approach that avoids triggering such issues in cases of network latency between user and platform.

Posted Nov 20, 2024 - 05:23 EST

Resolved
This incident has been resolved.
Posted Nov 14, 2024 - 17:07 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2024 - 15:45 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 14, 2024 - 14:42 EST
Investigating
We are aware of a problem where users are receiving login errors when logging in via KaseyaOne for Datto RMM on all platforms.

The Kaseya R&D Team is investigating this issue.

In the meantime, you may try logging in directly via auth.datto.com. In some cases where KaseyaOne Login is required as per your company's settings, this workaround may not work. A Datto RMM Administrator may disable this requirement: https://rmm.datto.com/help/en/Content/3NEWUI/Setup/Integrations/KaseyaOneUnifiedLogin.htm

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Nov 14, 2024 - 10:36 EST
This incident affected: Datto RMM (Pinotage (EU1), Merlot (EU2), Zinfandel (US West), Concord (US East), Syrah (APAC), Vidal (US East)).