Datto Backup for Microsoft Azure - Device Registration failures in the US-East region

Incident Report for Kaseya Inc

Resolved

The issue that was causing registration failures for Datto Backup for Microsoft Azure devices in the US-East region — specifically the error “The Virtual Network in the launch template could not be found” — has been resolved.

You should now be able to register devices without issue.

For ongoing updates and system status, please visit https://status.kaseya.com.
Posted Aug 04, 2025 - 19:06 EDT

Investigating

We are aware of a problem where Datto Backup for Microsoft Azure devices can experience a registration failure in the US-East region due to error "The Virtual Network in the launch template could not be found".


The Kaseya R&D Team is currently investigating the issue and working towards a resolution.


Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com/
Posted Aug 04, 2025 - 11:48 EDT
This incident affected: Datto / Unitrends Backup for Microsoft Azure (Device Registration).