Datto BCDR - RLY Remote Access - Inability to Remotely Access a Subset of Devices

Incident Report for Kaseya Inc

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 21:33 EDT

Update

We are continuing to investigate this issue.
Posted Apr 13, 2026 - 21:11 EDT

Investigating

We are aware of a problem where a subset of Datto BCDR devices cannot be accessed remotely through Relay via the UI or CLI, even though affected devices may still be checking in normally.

The Kaseya R&D Team is currently investigating.

Subscribe to the Kaseya Status Page for up-to-date information at https://status.kaseya.com
Posted Apr 13, 2026 - 21:10 EDT